Page 4 of 9 FirstFirst 123456789 LastLast
Results 61 to 80 of 172

Thread: Completely unsupported AO-On-Linux howto

  1. #61
    with wine 1.1.40 I can even run AO on the ATI "community driver".
    (ATI dropped support for a lot of older cards in linux last year.)
    Fixer issues

    Quote Originally Posted by heartless888 View Post
    fixers got 2 more hots since LE, which means their healing over time, more or less, went up 200%

  2. #62
    Quote Originally Posted by lusthorne View Post
    I find this very interesting. I've been playing mostly with cedega for years and I don't have this crashing issue.
    I should make more tests with cedega. After reading your post im 80% sure that I saw crash because i was dual logged the whole time!

    AO is not particularly friendly with alt-tabbing to begin with, and the extra alt-tab stuff in cedega (ie; minimize on focus loss) should actually be disabled for AO (which alone takes care of the majority of focus issues).
    Ah, thanks! Thats why I was not having this problem 1 year ago! I deleted my old profile and forgot to take care of config like I did before.

    I also recommend (if you dual log ao in full screen) to put your instances of AO on different desktops, and use hotkeys to flip desktops rather than using alt tab to flip active windows (even wine has problems with alt-tabbing in my experience so it's not unique to cedega).
    Its the first thing I tried after my first crash, but it was still happening... But I agree, I used to have less problem using ctrl+alt+left/right than alt+tab.

  3. #63
    Even with "minimize on focus loss" turned off, when I come back to AO, I got focus for mouse but not for keyboard... extra hit on alt and its working... :'(

  4. #64
    Quote Originally Posted by Tamalou View Post
    Even with "minimize on focus loss" turned off, when I come back to AO, I got focus for mouse but not for keyboard... extra hit on alt and its working... :'(
    Just out of morbid curiosity, what is your windowmanager? Myself I use kde/kwin and I use custom shortcuts for desktop flipping (namely meta(read: windows key)+leftarrow or meta+rightarrow) rather than ctrl + alt combos.

    It's possible it could be partially related to how the window manager manages focus, or it could be as simple as cedega not coping terribly well with alt key combos (just a theory, I have not tested this at all).

    Additionally it's been pointed out to me that if you hotkey shortcut to a different desktop, but you use your mouse to get back to cedega (like by clicking it on the taskbar) you may lose keyboard focus unless you flip desktops with hotkeys again. Not a situation I generally encounter just for being used to flipping desktops via hotkey all the time, but it's worth pointing out.
    Lusthorne - 220 Keeper | Isellthings - 220 Trader - PvP-Config
    Soupknotsie - 220 Doctor | Blabberus - 220 Crat
    and many more

    Boost outdoor sk in Pen/Inf or adjust missions for mixed factions
    A different approach to GTH
    Quote Originally Posted by Sterva View Post
    If you felt that I was implying that you are an idiot, it's probably because you are in fact, an idiot.

  5. #65
    http://ubuntuforums.org/showthread.php?t=1051483
    hardware cursor for wine!

    new arrow-cursor doesn't change form when hovering click-able items but you have old one following with slight delay.

    not sure if it registers clicks better than old, but at least it makes button targeting sooo much easier if you have problems with fps.
    You hit Tarasque with nanobots for 18280 points of melee damage.
    First shade with Blades of Boltar
    ---
    How much is enough?
    Member of Halinallet!

  6. #66
    I just can not get AO to run in linux. Always goes back to launcher without giving me anything but black screen.

  7. #67
    Quote Originally Posted by Crowena View Post
    I just can not get AO to run in linux. Always goes back to launcher without giving me anything but black screen.
    Running on Intel drivers perhaps? As in, probably a laptop with Intel GMA chipset.

    Had the same problem before reinstalling again, going to attempt another AO install now to see if I can get it working.
    Lupusceleri L220/30/70 Agent -- Advisor of Spartans -- equip endgame AR setup endgame def setup <3 Azs wearer of Cheree's pants
    Arrowsmith -- Arafellin -- Alphacenta -- Aesculapias -- Wolfseye -- Lysdexic


    TL5 enf twink: im out those MPs are to overpowered

    crattey: The Balance Discussion forum. Where common sense goes to die.

  8. #68
    Yeah, crappy intel integrated...

  9. #69
    Guide using PlayOnLinux posted on ubuntu forums:

    Easy Setup, No script, all legal, no crash, Newbie proof, Not even a Terminal window! 15-20 Min + Patch and you play

    'file&link' are sigle quoted
    [Button] are bracketed
    "select&Inputbox" are double quoted

    1.Get Files
    1.1 Get PlayOnLinux 'http://www.playonlinux.com/en/download.html'
    1.2 Get 'AdvancedWineConfiguration_3.5.1.pol' (bottom of download page)

    2.Install and run PlayOnLinux
    2.1 Install PlayOnLinux
    2.2 (On Ubuntu) [application] -> "Games" -> "playonlinux"

    3.Install Advanaced Wine Config (To enable -Opengl)
    3.1 CLick [Install]
    3.2 (Bottom left) click "Install a .pol package or an unsuppoerted application"
    3.3 Select "Install a .pol package"
    3.4 Browse to find 'AdvancedWineConfiguration_3.5.1.pol' you just downloaded
    3.5 Click [Next] and complete instalation wizard

    4.Install Ie4Linux (To Fix Patching Issue)
    4.1 Click [Install]
    4.2 Select "Internet" in the left Menu
    4.3 Select "Internet Explorer 6" From the list on the right
    4.4 Click [Apply] and Complete Installation Wizard

    5.Install Anarchy Online
    5.1 Click [Install]
    5.2 (Bottom left) click "Install a .pol package or an unsuppoerted application"
    5.3 Select Manual Installation -> [Next] -> [Forward]
    5.4 Select "Edit an application already installed" -> [Forward]
    5.5 Select "ie6" -> [Forward] -> [No]
    5.6 Browse to find the Anarchy Installer.exe ('AnarchyOnline_17.9.1_EP1_EP2_EP3.exe') -> [Open] -> [Forward]
    5.7 Complete Anarchy Instalation Wizard -> [Forward]
    5.8 At the "Do you want to create a shortcut ..." click [Yes]
    5.9 Browse to find 'Anarchy.exe' -> [Open] -> [Forward]
    5.10 Type a Name for your shortcut
    5.11 Select Desktop and/or Menu (or none if you only want it in the Playonlinux window)
    5.12 Second time you get the "Do you want to create a shortcut ..." click [No]

    6.Tweaks (Enable Sound and Open GL)
    6.1 Select your AnarchyOnline shortcut (Inside playOnLinux)
    6.2 Click [Configure this Application]
    6.3 [Forward] -> Select "Configure wine" -> [Forward]
    6.4 Tab[Audio] -> Set your sound (default works of me) -> [Apply] -> [Ok]
    6.5 Select "Use advanced wine configuraiton plugin" -> [Forward]
    6.6 [Forward] -> Select your AnarchyOnline Shorcut -> [Forward]
    6.7 select "DirectDrawRender" -> [Forward]
    6.8 select "OpenGl" -> [Forward] -> ...Wait... -> [Forward]
    6.9 [Cancel] to exit config menu

    7.Play
    7.1 Select your anarchyonline shortcut -> [run]

    THEORY

    In order to get the patcher to work you need Internet explorer from windows. I found a thread where it make you intal ie4linux and run the Anarchyonline in the ei4linux Wineprefix. Since Playonlinux makes separate Prefix for each game and allow you to insert more than one application in the same prefix, you can by default get you AO running inside Ie4linux prefix.

    Other Benifit
    PlayOnLinux also provide you with nice plug in and tools totweak your game, if you know your way around i suggest you take a peak at the advance wine config.

    Enjoy, Lou
    I am thrilled to say that ao finally runs under linux for me.

  10. #70
    Just upgraded to unbuntu 10.04 and YES!!!
    I can finally let "repeat when key pressed" to ON every times!!!!!!!!!


    Other subject here: im a bit afraid of new engine... AoC seems to not work very well with linux ma I wrong?
    Last edited by Tamalou; May 1st, 2010 at 12:32:09.

  11. #71
    Quote Originally Posted by lusthorne View Post
    Just out of morbid curiosity, what is your windowmanager? Myself I use kde/kwin and I use custom shortcuts for desktop flipping (namely meta(read: windows key)+leftarrow or meta+rightarrow) rather than ctrl + alt combos.

    It's possible it could be partially related to how the window manager manages focus, or it could be as simple as cedega not coping terribly well with alt key combos (just a theory, I have not tested this at all).

    Additionally it's been pointed out to me that if you hotkey shortcut to a different desktop, but you use your mouse to get back to cedega (like by clicking it on the taskbar) you may lose keyboard focus unless you flip desktops with hotkeys again. Not a situation I generally encounter just for being used to flipping desktops via hotkey all the time, but it's worth pointing out.
    I use gnome.
    Ill will try with custom shortcuts later.

  12. #72
    Quote Originally Posted by Tamalou View Post
    Just upgraded to unbuntu 10.04 and YES!!!
    I can finally let "repeat when key pressed" to ON every times!!!!!!!!!


    Other subject here: im a bit afraid of new engine... AoC seems to not work very well with linux ma I wrong?
    That was a bug in the xorg server, since Ubuntu locks up their packages every half-yearly release cycle it can take a while to let the bugfixes from each project trickle through.

    I tried to get AO working on an Intel GMA945 graphics card btw, but it just doesn't work with Wine. Get a black screen and.. well, bleh.
    Lupusceleri L220/30/70 Agent -- Advisor of Spartans -- equip endgame AR setup endgame def setup <3 Azs wearer of Cheree's pants
    Arrowsmith -- Arafellin -- Alphacenta -- Aesculapias -- Wolfseye -- Lysdexic


    TL5 enf twink: im out those MPs are to overpowered

    crattey: The Balance Discussion forum. Where common sense goes to die.

  13. #73
    I've been playing AO on ubuntu 9.10 for about a week now using wine version 1.1.43. So far quality seems to be about 95% of what I experienced in windows.. so I'm pleased with it. I did notice one issue that I felt I should pass along should anyone else using a low-end PC such as myself encounter.

    I noticed that a few of my characters were completely unable to move when they logged in (less than 1 FPS) while others were fine. I traced the problem down to one line in the Char.cfg located in the prefs/<username>/<char-id> directory. It seems as though my particular setup hates the MouseLagFix option if it is enabled (1). Disabling MouseLagFix (changing 1 to 0) makes things work normally.

    On another note. I haven't noticed a difference when using the renice with sudo fix mentioned earlier. Can anyone else tell a difference?

  14. #74
    Just like to say I got AO working using the method the dev posted. The only weird thing is (apart from a little lag) is that I need to do alt-ctrl-backspace to actually get the game to load from the launcher, otherwise it just sits at a black screen.

  15. #75
    Quote Originally Posted by peterrjg View Post
    Just like to say I got AO working using the method the dev posted. The only weird thing is (apart from a little lag) is that I need to do alt-ctrl-backspace to actually get the game to load from the launcher, otherwise it just sits at a black screen.
    What graphics card?

  16. #76
    Quote Originally Posted by Crowena View Post
    What graphics card?
    Nvidia 9600GT, using proprietary drivers. Trying to go windowed mode doesn't work at all. Stays at a black screen. Can hear the loading music etc, but no visuals.

  17. #77
    Check your resolution (utrla high resolutions doesnt work), perhaps this helps
    Level 200 Nanomage Nano-Technician on Rimor speaking... - Unit Commander of Knights of Ka
    Toons:(*=froobs)
    Zzzzzzwap* (inofficial main),
    Krisplin* (main, but buff whore),
    Theophrastus* (piercing doc - aka froob shade)
    Kosminski (Shade - Yes, i went paid...)
    Codeleet (s10 & pvp)
    ~ Founder of TL5+ - Rimor TL5+ froob raid force ~ || ~ My Tweet... ~

  18. #78
    Quote Originally Posted by Lupusceleri View Post
    That was a bug in the xorg server, since Ubuntu locks up their packages every half-yearly release cycle it can take a while to let the bugfixes from each project trickle through.
    O'RLY?
    Check who posted the xorg trackbug link on page 3?

    <3 u lupu!

  19. #79
    Oooo got an official ubuntu update with install of winetricks (i did not have before) and update of wine... strange since Im already 1.1.43...

    As sidenote i can say 1.1.42 was still crashing on same infamous rooms from LE miss, dunno for .43 yet

  20. #80
    Quote Originally Posted by DocJones View Post
    Check your resolution (utrla high resolutions doesnt work), perhaps this helps
    Hmm, I'll try that. In Windows it runs at 1920x1080 not a drama, and that's what I'm using in Ubuntu and it runs OK at that full screen. It's windowed mode where it doesn't work.

Page 4 of 9 FirstFirst 123456789 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •