Results 1 to 3 of 3

Thread: Unable to purchase funcom points?

  1. #1

    Unable to purchase funcom points?

    I have been unable to purchase funcom points both via "Steam Wallet" on my account created via Steam, and also on a non-steam account using CC.

    Just posting here to get some attention, as this issue has existed for more than 4 days. (Yes I have filed a support ticket).

    Anyone else encountering this issue?

  2. #2
    FYI - In both cases the issue was related to my account being recently created. If you attempt to buy funcom points too soon after creating the account, it gets disabled apparently.

    Resolved by funcom support, thanks.

  3. #3
    I've also been having trouble trying to use steam to buy FC points. I tried it a few days ago and got directed to a 404 error page when I clicked on the button to go to Steam in the in-game store window. Tonight I tried again and while it let me get to Steam and log in, it brought me back to the "Pending" screen and if I try to click on the "Process payment" Steam button again it just gives me an error page. I sent in a ticket to FC support so hopefully they can resolve it - I'd like to spend money, it's never been so difficult :P

    FWIW my account isn't new, so I hope they can figure out what is wrong.
    220! Bureaucrat - I finally did it, get the camera mom!
    95 Fixer
    40 Adventurer (I WILL BE A DRAGON SOMEDAY)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts